Welcome, Guest. Please Login
 
  HomeHelpSearchLogin FAQ Radified Ghost.Classic Ghost.New Bootable CD Blog  
 
Page Index Toggle Pages: 1
Send Topic Print
Boot failures on cloned disk (Read 3665 times)
Incanus
Ex Member




Back to top
Boot failures on cloned disk
Jun 26th, 2008 at 7:13am
 
Hope someone can help a novice!

Two hard disks, one NTFS partition each, C:\ & D:\. Running Win XP Pro SP2.

Bought new 500Gb disk to replace C:. Swapped it for D: in PC, used Ghost 2003 to do a disk-to-disk clone of C:, all seemed to go well. Moved jumpers, rebooted, etc, all seemed fine - XP starts up.

However, most of the time when I start the PC I get the old "Windows could not start because the following file is missing or corrupt: \windows\system32\config\system" and I shold run boot to the XP CD and run a repair. If I ctrl-alt-del to reboot, I may get this one or two or three more times, but eventually the PC boots up normally.

I could boot to XP CD and replace the "system" file, but am not sure what the effects would be on my system - the current file is much larger than the older one.

I've taken to leaving the PC on, and the few other times I've had to restart, I've managed to get past this error when necessary with restarting again. Been meaning to register here and post, but then...

Last night I had to restart and this time got "Windows could not start because of an error in the software. Please report this problem as: load needed DLLs for HAL."

Please - does anyone know what I can do to fix this?

Many thanks indeed.
 
 
IP Logged
 

wp
Technoluster
***
Offline


I Love Radified!

Posts: 200
california


Back to top
Re: Boot failures on cloned disk
Reply #1 - Jun 27th, 2008 at 11:31pm
 
i can't tell from your post, but a crucial step is shutting down the computer and physically removing the cloned disk from the system.  xp goes ape-poop because of identical sids if u boot with both disks still in machine.

alan
 
 
IP Logged
 
Brian
Demigod
******
Offline



Posts: 6303
NSW, Australia


Back to top
Re: Boot failures on cloned disk
Reply #2 - Jun 27th, 2008 at 11:39pm
 
Incanus,

To get you started...

http://support.microsoft.com/kb/307545
 
 
IP Logged
 
TheShadow
Kahuna
*****
Offline


Old Ghost user!

Posts: 613
Florida, USA


Back to top
Re: Boot failures on cloned disk
Reply #3 - Jun 28th, 2008 at 11:17am
 
It's only a stab in the dark, but since it does boot sometimes, the problem can't be an incorrect or missing file, or it would never boot up at all.

The first thing I would do is run
chkdsk /r
  (repair) on that drive.
You can do that right from the RUN box on the Start menu.

Chkdsk can repair a multitude of problems in the file structure on the HD.

I've had a HD from a customer's PC, so badly damaged that they would not boot at all.
I just removed that HD and put it on my own system as a Slave and then ran Chkdsk /r on it and it was repaired and booted normally when I put it back in it's own computer.

Give that a try. Roll Eyes

Cheers mate!
The Shadow  Cool

 
WWW  
IP Logged
 
Incanus
Ex Member




Back to top
Re: Boot failures on cloned disk
Reply #4 - Aug 12th, 2008 at 5:42am
 
Thanks for your replies and apologies for not reporting back earlier.

Brian, thanks - I had already checked out the MS site; I didn't want to go ahead and just replace my system32\config\system file with a much older & smaller one without knowing what the implications would be.

TheShadow - good advice; before chkdsk I tried running SpinRite on the drive, as I'd heard that it can do a better job in some ways. It found nothing wrong, so I gave chkdsk /r a try. Not sure what it found, if anything, as I didn't watch it right through; but unfortunately it didn't fix things.

I'm coming to the conclusion that wp may well have been right and I must have left the original HDD connected on first boot of the new clone. I'm not sure now of exactly what order I did things in, but perhaps I just swapped the disks' order, leaving the old one as a slave, thinking that would be okay. The behaviour I've got would accord with my reading around the subject more now, although I've not read of anyone with the exact same error.

I think it's probably time to back up and reinstall XP afresh on the disk before things go catastrophically wrong  - perhaps trying a repair first. Lesson learned.

Thanks again for your answers, everyone!
 
 
IP Logged
 
TheShadow
Kahuna
*****
Offline


Old Ghost user!

Posts: 613
Florida, USA


Back to top
Re: Boot failures on cloned disk
Reply #5 - Aug 12th, 2008 at 7:57am
 
Since 99.99% of the people in the world DON'T have Spinrite6, I don't even mention it.  But it checks the surface of the HD and not the actual files or file structure, thusly I run Chkdsk /r which IS specifically designed to repair windows problems.

I think I'l go thru the backup and restore again, after purging the original C: drive of every unneeded file, and then running chkdsk /r on it to make sure it's 100% OK before doing the cloning operation.

Two other, very good, cloning programs (also FREE) are Seagate's "Sea Tools" and Maxtor's "Max Blast".  They are actually the same program written by Acronis True Image, and both work great for cloning a hard drive.  They both work just fine for Vista too.
You must have either a Seagate or Maxtor drive somewhere in the cloning process for either program to work.

Good Luck,
The Shadow  Cool
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print