Welcome, Guest. Please Login
 
  HomeHelpSearchLogin FAQ Radified Ghost.Classic Ghost.New Bootable CD Blog  
 
Pages: 1 2 
Send Topic Print
Errors on page when using IE 8 (Read 9739 times)
NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Errors on page when using IE 8
Oct 2nd, 2010 at 11:05am
 
Rad

Don't know if you use IE 8, but I noticed an *Warning* notice down at the bottom of the IE 8 interface--the *Status Bar* line.

This is when on the forum's main *Home* page--it says:

Quote:
!  Done, but with errors on page.


Double clicked the ! symbol and this is the results when copied to the Clipboard and pasted here:

Quote:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.5; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Fri, 1 Oct 2010 15:13:30 UTC


Message: Object expected
Line: 52
Char: 1
Code: 0
URI: http://radified.com/cgi-bin/yabb2/YaBB.pl


A similar warning occurs on other sub-pages, but the line # of the error changes--so when on the page after clicking on *Rad Web Site*:

Quote:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.5; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Sat, 2 Oct 2010 15:53:56 UTC


Message: Object expected
Line: 55
Char: 1
Code: 0
URI: http://radified.com/cgi-bin/yabb2/YaBB.pl?board=forum_website


If I click on a particular thread:

Quote:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.5; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Sat, 2 Oct 2010 15:55:04 UTC


Message: Object expected
Line: 73
Char: 1
Code: 0
URI: http://radified.com/cgi-bin/yabb2/YaBB.pl?num=1283114394


Pages load fine, so I don't know if this of any particular significance....but thought I'd point it out to you!
 

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 

Christer
Übermensch
*****
Online



Posts: 1283
Sweden


Back to top
Re: Errors on page when using IE 8
Reply #1 - Oct 3rd, 2010 at 2:22am
 
I too use IE 8 and have the same "problem" on the RADIFIED home page but only prior to logging in to the forum (I think).
 

Old chinese proverb:
If I hear - I forget, If I see - I remember, If I do - I understand
 
IP Logged
 
Dan Goodell
Special Guest
*****
Offline



Posts: 552
N California


Back to top
Re: Errors on page when using IE 8
Reply #2 - Oct 3rd, 2010 at 5:53am
 
LOL!  I find it (perversely) humorous that IE would complain about "errors" when all the other browsers don't have a problem with the page.  IE has a long history as being the least compliant browser on the market.  Version after version, Microsoft steadfastly refuses to adhere to the W3C standards.  (And from what I can see, IE9 won't be any different.)

BTW, this symptom is not limited to IE8, but is also seen in IE6 and IE7, too.  FTR, Firefox, Chrome, and Safari don't complain of any problems.

IE is a well-known PITA amongst website designers.  I've spent countless frustrating hours having to tweak webpages so they display more or less as intended in IE.  After designing a webpage and making it W3C compliant, it will display the same in all the other browsers, but not IE.  You have to "break it" to accommodate IE's idiosyncrasies.  Oftentimes, that means I have to dumb down my pages more than I'd like for the other browsers, just so they don't become unreadable in IE.  The alternative (and a number of professional sites actually do this!) is to use javascript to sniff out what browser is being used and return one of two versions of the page -- either a IE-specific page, or a W3C-compliant page for everybody else.

Venting aside, I think a "code 0: object expected" error is a javascript issue.  I'm no javascript expert, but it seems like the "error" is being flagged in the area where javascript is rendering the time and date in the top-left corner of the page.

If I am not logged in, I see the IE error msg but no time and date at the top of the page.  If I am logged in, I see the time and date but no error msg.  I wonder if the js function is left to work with an undefined variable if you aren't logged in?

As far as I can see, this isn't something to lose any sleep over.

 
 
IP Logged
 
NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Re: Errors on page when using IE 8
Reply #3 - Oct 3rd, 2010 at 10:28am
 
@
Dan Goodell

Quote:
If I am not logged in, I see the IE error msg but no time and date at the top of the page.  If I am logged in, I see the time and date but no error msg.

Are you using the *default* forum template--I don't have the *time/date* in the upper left corner whether logged in or not!  I'm using the *midnyte* template.

Warning shows up whether logged in or not on my system and using the *midnyte* template!



@
Christer

Quote:
I too use IE 8 and have the same "problem" on the RADIFIED home page but only prior to logging in to the forum

Which template are you using for the forum?



Quote:
As far as I can see, this isn't something to lose any sleep over.

From my perspective, I have to agree--just wanted to bring it to Rad's attention!
 

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 
Christer
Übermensch
*****
Online



Posts: 1283
Sweden


Back to top
Re: Errors on page when using IE 8
Reply #4 - Oct 3rd, 2010 at 1:23pm
 
NightOwl,

Quote:
Which template are you using for the forum?

blk_gry3D

Is that the default?
 

Old chinese proverb:
If I hear - I forget, If I see - I remember, If I do - I understand
 
IP Logged
 
Dan Goodell
Special Guest
*****
Offline



Posts: 552
N California


Back to top
Re: Errors on page when using IE 8
Reply #5 - Oct 3rd, 2010 at 1:29pm
 
NightOwl wrote on Oct 3rd, 2010 at 10:28am:
Are you using the *default* forum template--I don't have the *time/date* in the upper left corner whether logged in or not!I'm using the *midnyte* template.

I'm using the "blk_gry3d" template, but as near as I can tell, it's a duplicate of "midnyte".  I can't see any difference between the two of them.

I tried "midnyte" and a few of the other choices, with consistent behavior.  When logged in I get the time and date in the upper-left corner.  When not logged in, no time and date, plus IE error msg.

Are you running any javascript blockers?

 

forum-js.jpg (59 KB | 273 )
forum-js.jpg
 
IP Logged
 

Spanky
Radmeister
**
Offline


Rad's non-Admin Test profile
in Seamonkey

Posts: 73
Same as Rad


Back to top
Re: Errors on page when using IE 8
Reply #6 - Oct 3rd, 2010 at 4:20pm
 
There was a problem with the clock. Brian first noticed it when I installed Y2.4. It has been a while, so I'm fuzzy on the details. I brought it to the attention of the YaBB guys, and they basically said, 'you're the only one with the problem'.

I use several 'mods' and I suspect it might be due to a mod, which modifies code. Sometimes these mods can break other stuff if the scripter is not careful.

I coulda played with the various mods, but it didn't seem worth the trouble.

I was expecting Y2.5 to fix the issue, but they haven't updated all the mods I use (with Y2.4). Yet. Y2.5 is installed. See if you get the problem here:

http://radified.com/cgi-bin/yabb25/YaBB.pl
 
WWW  
IP Logged
 
Brian
Demigod
******
Offline



Posts: 6304
NSW, Australia


Back to top
Re: Errors on page when using IE 8
Reply #7 - Oct 3rd, 2010 at 5:56pm
 
Rad,

On that link, the error is gone and the clock is working when I'm offline. Great.
 
 
IP Logged
 
NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Re: Errors on page when using IE 8
Reply #8 - Oct 3rd, 2010 at 11:00pm
 
@
Dan Goodell

Quote:
I tried "midnyte" and a few of the other choices, with consistent behavior.  When logged in I get the time and date in the upper-left corner.  When not logged in, no time and date, plus IE error msg.

Are you running any javascript blockers?

No, no blocking of javascript!

But here's the weird thing--I've have never had the clock function in the upper left corner--whether Logged in, or not.  On Rad's link to the 2.5 forum version, I do see the clock--and I'm not Logged in! 

I went into the *User CP* (Control Panel) of the current 2.4 forum, and on the *Options* page there is a choice *Enable dynamic clock at the top of the page?*--it was checked.  After I *unchecked* that box and saved the changes--now I do have the clock!--and no Warning message when logged in!!!!  (I will try later to see what happens when not Logged in.)

I would have thought checking that option would *enable* the clock function--but, oh no, not on my system (I swear--everything is always counter intuitive on my system)!!!!

Anyone else--what is the setting in your *User CP--Options*--clock function has a check or is unchecked in order to get the clock in the upper left corner?



@
Spanky

Using the link to the v2.5 forum, I see the clock function even though I am not *Logged in*, and I do not see an Warning symbol on the status line.
 

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 
Christer
Übermensch
*****
Online



Posts: 1283
Sweden


Back to top
Re: Errors on page when using IE 8
Reply #9 - Oct 4th, 2010 at 2:55am
 
Quote:
Anyone else--what is the setting in your *User CP--Options*--clock function has a check or is unchecked in order to get the clock in the upper left corner?

It was unchecked. The clock was there but it displayed the time when the page was opened. That is "static" to me as opposed to "dynamic" (ticking away). When I checked it, the clock was removed.
 

Old chinese proverb:
If I hear - I forget, If I see - I remember, If I do - I understand
 
IP Logged
 
Dan Goodell
Special Guest
*****
Offline



Posts: 552
N California


Back to top
Re: Errors on page when using IE 8
Reply #10 - Oct 4th, 2010 at 3:44am
 
Same symptoms here.  Checkbox was clear.  Tested with IE7 on the active (v2.4) forum pages.  No time display and "Done, with errors" when not logged in, vs. time display and no error when logged in.

When I enable the checkbox, I get no time display and "Done, with errors" under both scenarios -- logged in or logged out.

FTR, I looked at the v2.5 testbed page and I see time display and no error when logged out.




 
 
IP Logged
 

NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Re: Errors on page when using IE 8
Reply #11 - Oct 4th, 2010 at 8:42am
 
@
Dan Goodell

From your reply #2:

Quote:
BTW, this symptom is not limited to IE8, but is also seen in IE6 and IE7, too.  FTR, Firefox, Chrome, and Safari don't complain of any problems.

At least for FireFox, it does not report the *Warning* icon and message in the *Status* line like IE 8, but if you launch the *Error Console* from the *Tools* listing on the menu bar, you get the following in the attached screen capture.

So, the errors are there, just not reported overtly.

 

FireFox_Errors.JPG (91 KB | 276 )
FireFox_Errors.JPG

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 
NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Re: Errors on page when using IE 8
Reply #12 - Oct 4th, 2010 at 8:47am
 
@
Christer

Quote:
That is "static" to me as opposed to "dynamic" (ticking away). When I checked it, the clock was removed.

Well, at least it's not just my system then  Smiley !

It does not actively *tick*--not showing seconds--but it does update and increments the minutes!

Edited:
Correction:  It is not *dynamic*--the minutes only update when there's a page refresh!  They are static if you don't refresh!
 

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 
NightOwl
Radministrator
*****
Offline


"I tought I saw a puddy
tat..."

Posts: 5801
Olympia, WA--Puget Sound--USA


Back to top
Re: Errors on page when using IE 8
Reply #13 - Oct 4th, 2010 at 9:03am
 
@
Spanky

On Rad's test page for the forum software v2.5: 

http://radified.com/cgi-bin/yabb25/YaBB.pl

The clock does update *dynamically* without a page refresh.
 

____________________________________________________________________________________________

No question is stupid ... but, possibly the answers are Wink !
 
IP Logged
 
Christer
Übermensch
*****
Online



Posts: 1283
Sweden


Back to top
Re: Errors on page when using IE 8
Reply #14 - Oct 4th, 2010 at 9:29am
 
I have date, hours, minutes and seconds that get updated on page refresh. I haven't tested v2.5.
 

Old chinese proverb:
If I hear - I forget, If I see - I remember, If I do - I understand
 
IP Logged
 
Pages: 1 2 
Send Topic Print