Welcome, Guest. Please Login
 
  HomeHelpSearchLogin FAQ Radified Ghost.Classic Ghost.New Bootable CD Blog  
 
Page Index Toggle Pages: 1
Send Topic Print
Problem with Epson USB printers and Windows 7 (Read 5743 times)
cardinal23
Nuclear Grade
****
Offline


I love YaBB 1G - SP1!

Posts: 250


Back to top
Problem with Epson USB printers and Windows 7
Apr 13th, 2010 at 4:27pm
 
Problem with Epson USB printers and Windows 7 – Need printer, USB, Windows-7 expertise!

Prediction:  This is a USB problem.

Windows 7 Professional, 64-bit
Epson CX-4800 or Epson CX-7400 – problem is identical on both

Problem summary:
I have 2 seemingly identical Windows-7 / Epson printer pairs.  One pair worked great.  The other pair is SLOW.
When I print a Test Page, it takes 10 seconds to see “Test Page sent”.  It then takes another 40 seconds until the Epson “progress” window appears and printing begins.

IMPORTANT OBSERVATIONS:
I actually have TWO Windows 7 64-bit PCs and TWO CX-7400 printers (and ONE CX-4800 printer)

Call the players:
Ken’s (Bad) PC (HP Pavillion – brand new) and Ken’s printer (CX-7400)
Don’s (Good) PC (Desktop) and Don’s printer (CX-7400)

Don’s PC prints to EITHER printer fine – no delay – boom!
Ken’s PC prints to NEITHER printer correctly.  Both have these same nasty delays.

Note:  As a test, I hooked up a CX-4800 – Epson’s predecessor to the CX-7400.  It acted exactly the same (SLOW) as the CX-7400 on Ken’s PC.

Windows-7 and Epson printers:
When one first attaches an Epson printer to a Windows-7 PC, software gets installed and the printer works FAST – but envelopes print misaligned.  This is the case for BOTH the CX-7400 and the CX-4800.  However, the printer installed is the Epson ESC/P-N (NOT the CX-7400 or CX-4800).  If you then right-click on the ESC/P-N and choose Printing Preferences, you see a button that reads “Upgrade to latest version.”  If you click on that driver and software updates occur.  The printer changes to CX-7400 from ESC/P-N.  Now envelopes work correctly but it is VERY, VERY SLOW.

Note: This is the behavior on Ken’s (Bad) PC.  Don’s (Good) PC does NOT have these issues.  Don’s PC behaves correctly.

I have compared LINE-BY-LINE-BY-LINE all printer properties and settings between Don’s PC and Ken’s PC.  They are IDENTICAL. Same options.  Same drivers.

We have tried different cables. 

USB comparisons (quite different):
Don’s (Good) PC shows this:
Universal Serial Bus Controller
      Standard enhanced PCI to USB Host Controller
      Standard Open HCB USB Host Controller
      USB Root Hub
      USB Root Hub
USB Virtualization
      USB Virtualization Connection Driver

Ken’s (Bad) PC shows this:
      Generic USB Hub
      Generic USB Hub
      Intel(R) 5 Series/3400 Series Chipset family
      Intel(R) 5 Series/3400 Series Chipset family
      USB Composite Device
      USB Composite Device
      USB Mass Storage Device
      USB Printing Support      (interesting)
      USB Root Hub
      USB Root Hub
 
 
IP Logged
 

MrMagoo
Übermensch
*****
Offline


Resident Linux Guru

Posts: 1026
Phoenix, AZ (USA)


Back to top
Re: Problem with Epson USB printers and Windows 7
Reply #1 - Apr 14th, 2010 at 12:19pm
 
I'd start by completely uninstalling the USB drivers from the slow computer and reinstall them manually before hooking the printer back up.  Make sure you have the latest driver from Epson's website. 

Another thing to try is unplugging all the other usb devices from the slow computer.  Something else could be interfering on the USB root hub.

Does the slow computer have any antivirus?  You might try disabling it for a min and print a test page - just to see if it's interfering.  Antivirus has caused stranger problems.

Also, I assume the slow computer has been rebooted at least once since the problem started, but I always regret not covering the bases... So try a reboot if you haven't.
 
WWW  
IP Logged
 
OldCasper
Radmeister
**
Offline


I Love Ghost!

Posts: 92
Florida, USA


Back to top
Re: Problem with Epson USB printers and Windows 7
Reply #2 - Jul 18th, 2010 at 11:09am
 
If the printer drivers you're using were not specifically written for Windows 7, you may want to contact Epson to see if they have any updated drivers for Win-7.

My own Epson printers are working fine on Windows 7 Ultimate 64, with the Vista drivers.  Go figure!

Casper
 

A man with experience is never at the mercy of a man with an argument.
 
IP Logged
 
vinnie
N00b
Offline


I Love Radified!

Posts: 1


Back to top
Re: Problem with Epson USB printers and Windows 7
Reply #3 - Aug 25th, 2010 at 2:24pm
 
I have same problem as "Cardinal23 and the bad pc."
I am using a HP pc with windows 7 64bit and when trying to print to an Epson Workforce 610 or 600 using the latest drivers everything grinds toa halt and if lucky it will print job will print what you requested.

When however using the basic ESC/P-N driver everything works very fast and efficiently however then you cannot use any of the setup/maintenance/other features of the printer e.g. printing using only black ink or photo settings.

So i am baffled by this problem and have spent hrs on the phone to Epson technical but they have no idea what is causing this problem.

Does anyone have a solution to this strange problem?
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print